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Building a Network and Performing a Steady-State
Analysis

In constructing a distribution network for this lesson, you do not need to be
concerned with assigning labels to pipes and nodes, because Bentley WaterCAD V8i
will assign labels automatically. When creating a schematic drawing, pipe lengths are
entered manually. In a scaled drawing, pipe lengths are automatically calculated from
the position of the pipes’ bends and start and stop nodes on the drawing pane.

In this network, the modeling of a reservoir connected to a pump simulates a connection to the main water
distribution system. Simplifying the network in this way can approximate the pressures supplied to the system
at the connection under a range of demands. This type of approximation is not always applicable, and care
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should be taken when modeling a network in this way. It is more accurate to trace the network back to the
source.

In this lesson, you will create and analyze the network shown below. You will use a scaled background
drawing for most of the network; however, four of the pipes are not to scale and will have user-defined
lengths.
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Step 1: Create a New Project File

1. From the welcome dialog, click Create New Project and an untitled project opens. Or click File > New to
create a new project.

welcome x|

? Quick Start Lessans

Create New Project

O pen Existing Project

¥ Shaw This Dislog at Startup

11/15/2010 [08.11.02. 24 Close Help
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2. Click the Tools menu and select the Options command. Click the Units tab. Since you will be working in
System International units, click the Reset Defaults button and select System International.

¥ Reset Defaults - .

|@ Sywstem International [:

@ 1S Custornarsy

3. Verify that the Default Unit System for New Project is set to System International. If not, select from the
menu.

4. Click the Drawing tab to make sure Drawing Mode is set to Scaled.

opons x|

Drawing Scale
Dirawing mode: IS::aIeu:I j
Plot gzale factor 1 om = |4EI.I:IEI m

5. Set the Plot Scale Factor 1 cm = 40 m.

6. Click OK.
7. Set up the project. Choose File > Project Properties and name the project Lesson 1—Steady State
Analysis and click OK.
zl
Title: ILesson 1-Steady State Analysiz
File Mame: IE:\Program Files'BertiepywaterGEMS Lessons\MYLESSONT.
Engineer: I
Cormpany: ||
Date: [ 272772008 -1
Motes:
=]
=

QK I Cancel | Help |

8. Choose File > Save as. In the Save File As dialog box, browse to the My
Documents/Bentley/WaterGEMS folder.
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saveas 21|

Savein | ) WaleiGEMS = o2 E

My Recent
Documents

Ej

Desktop

o

My Documents

-

o

My Computer
-

-
LSS File pame: [MYLESSONT | Save

Places
Saveasiype:  [waleiGEMS Project Files [“wig) | Cancel |

9. Enter the file name MYLESSON1.WTG for your project, and click Save.
Step 2: Lay out the Network

3

1. Select Pipe from the layout toolbar.

2. Move the cursor on the drawing pane and right click to select Reservoir from the menu or click from

the toolbar.

3. Click to place R-1.

4. Move the cursor to the location of pump P-1. Right-click and select Pump from the shortcut menu.

Done

Bend
Junction
Hydrant
Tank

® Reservair

‘ariable Speed Pump Battg

FCW

GPY

PEY

PRY

Psv

TCW

Isolation Yalve

Turbine

Petiodic Head-Flow

Air Yalve
Hydropnieumatic Tank
Surge Valve

Check Yalve

Rupture Disk,

Discharge To Atmosphere
Crifice Between Pipes
‘alve With Linear Area Change
Surge Tank

5. Click to place it.
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Right click to select Junction from the menu and click to place J-1.
Click to place junctions J-2, J-3, and J-4.
Click on J-1 to finish.

o »®» =2

Right-click and choose Done from the menu.
4

Bl pq  PMP-1p,

10. Create J-5.
a. Select the Pipe layout tool again.
b. Click junction J-3.
¢. Move the cursor to the location of J-5, and click to insert the element.

d. Right-click and select Done.

11. Lay out junction J-6 and the PRV by selecting the Pipe layout tool and placing the elements in their
appropriate locations.

Be sure to lay out the pipes in numerical order (P-7 through P-9), so that their labels correspond to the
labels in the diagram. Right-click and select Done from the menu to terminate the Pipe Layout command.

12. Insert the tank, T-1, using the Pipe layout tool. Pipe P-10 should connect the tank to the network if you
laid out the elements in the correct order.
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13. Save the network by clicking M or choose File > Save.

Save

Step 3: Enter and modify data

+ Dialog Boxes—You can use the Select tool e and double-click an element to bring up its Properties
editor.

«  FlexTables—You can click FlexTables (3 7 to bring up dynamic tables that
allow you to edit and display the model data in a tabular format. You can edit the data as you would in a
spreadsheet.

* User Data Extensions—The User Data Extensions B+ feature (Tools menu > User Data Extensions)
allows you to import and export element data directly from XML files.

¢ Alternative Editors—Alternatives are used to enter data for different “What If?” situations used in
Scenario Management.

Entering Data through the Properties Editor
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To access an element’s property editor, double-click the element.

1. Open the Reservoir Editor for reservoir R-1.

E|
EE -] @ iz 7]
[ <show all |

18] 28 -
G
Motes
GIS-Ds <Collection: 0 itermns:
Hyperlinks <Collectior: O items>
E <Geometry>
# [m) -B7.30
' [m) 234
E Active Topology
|5 Active? True
E Operational
Controls «<Collectior::
E Physica
Elevation [m] 0.00
Zone <Maone

Hydraulic Grade Pattern Fixed
E Transient [Physical)

Elevation [Inlet/Outlet [nwvert] 0.00
E Water Quality

Age (Initial] (hours) 0.000
Concentration [Initial] (mgsL) 0.0
Iz Constituent Source? False
Trace [Initial] [%] 0o
E Results
Hydraulic Grade [m) M)
Flows [Out net] [Lig] M)
Flows [In net] (L= M)

Has Calculation Meszzages M| [MAA)
E Results [Transient]

Head [Maximum, Transient] || [NA&]

Head [Minimumm, Tranzsient] [ [NA&]

Pressure [Masimumn, Transie [NA&]

Pressure [Minimum, Transier) [NA&]

Air Yolume [Maximum, Trang (NAA]

Wapor Wolume [Masimum, Tr [MAA) o
E Results [Water Quality]

Age [Calculated) [hours) M) -

Label
Descriptive label for this element.

2. Enter the Elevation as 198 (m).
3. Set Zone to Connection Zone.

a. Click the Zone menu and select the Edit Zones command, which will open the Zone Manager.

b. Click New j .

c. Enter a label for the new pressure zone called Connection Zone.
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x
j X % v Motes:
| ' =

| Label
[& Connection Zone

Cloze | Help |

d. Click Close.

e. Select the zone you just created from the Zone menu.

4. Click tank T-1 in the drawing to highlight it and enter the following:
Elevation (Base) = 200 m
Elevation (Minimum) = 220 m
Elevation (Initial) =225 m
Elevation (Maximum) = 226 m
Diameter = 8 m
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Section = Circular
Set the Zone to Zone 1 (You will need to create Zone-1 in the Zone Manager as described above.)

|
[T =l & e oz 7]
| <Show &l |
18] 48
Label T1
Motes
GIS-Ds <Collection: 0 itermns:
Hyperlinks <Collectior: O items>
E <Geometry>
# [m) 338,60
' [m) 302.81
E Active Topology
|5 Active? True
E Demand
Demand Caollection <Collection: 0 iterns:
Unit Demand Collection <Collection: 0 itermns:
E Operating Aange
Operating Range Type Elevation
Elevation [Basze] [m) 200.00
Elevation [Minimum] [m] 220.00
Elevation [Initial] [m) 225.00
Elevation [k aximum] [m] 226.00 |
Usze High Alarm? Falze
Usze Low Alarm? False
E Operational
Controls «<Collectior::
E Physica
Elevation [m] 0.00
Zone Zone -1
Wolume [Inactive] (L] 0.00
Inztallation v'ear 1]
Section Circular
Driameter [m) 8.00
Wolume Full [Calculated] (ML [MAA)
Has Separate Inlet? Falze
E Transient [Reporting]
Feport Period [Transient] 0
E Water Quality
Age (Initial] (hours) 0.000 -
<General>

Quick Start Lessons

5. Click pump PMP-1 in the drawing to highlight it.
a. Enter 193 (m) for the Elevation.

b. Click in the Pump Definition field and click on Edit Pump Definitions from the drop-down list to open
the Pump Definitions manager.
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B4 Pump Definitions .

AXxEBma e

| Head |Efficienc:y| tdotar I Transientl Libraryl MHaotes I

Label | Pump Definition Type: [

Pump Power:

ID.D K

No Results to Graph

c. Click New j to create a new pump definition.

d. Leave the default setting of Standard (3 Point) in the Pump Definition Type

menu.
e. Right click on the Flow column and select the Units and Formatting
command.
f. In the Set Field Options box set the Units to L/min.
Preview
’7Value: I‘I— Lémiir
Cancel |
Lini: =
Hel
Dizplay Precizion: ID— 4p|
Farmat: lm
g. Click OK.
h. Enter the following information:
Fliowy Head
{Limin] (m)
Shikoff: 0,0a 30,00
Design: 3,800,00 27.40
Mazx. Operating: 7,500.00 24.80

2-10
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i.  Highlight Pump Definition - 1 and click the Rename button. Change the name to PMP-1.

& Pump Definitions |
j e % [0 g - Head |Efficienc:y| I ator I Transientl Libraryl Motes I
|
Label | Pump Definition Type: IStandard [3 Paint) j
Flow Head
(L frnin) ()
Shutoff: a 30,00
Design: 3,800 27.40
Max, Operating: 7,500 24.80
PMP-1
30.00 120.0 £
25.00 100.0 3
E 20.00 80.0 O
= 15.00 60.0 o
5 S
T 10.00 40.0 2
5.00 SO
0.00 0.0 2
i 10,000 20,000 30,000 40,000
Flow (L/min)

Coefficients: a = 30.00 m; b = 5.827e-004 m/(L/min)"c; c = 1.015

| Cloze | Help |
4

j. Click Close.

k. In the Properties editor, select PMP-1 from the Pump Definition menu.

6. Highlight valve PRV-1 in the drawing. Enter in the following data:

Status (Initial) = Active

Setting Type= Pressure

Pressure Setting (Initial)= 390 kPa
Elevation =165 m

Diameter (Valve) = 150 mm

Create Zone-2 and set the valve’s Zone field to Zone-2.
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Properties - PRY - PRY¥-1 {45)

[

[FRv-1 =l & e oz 7]
| <Show &l |

45

PRY-1

GIS-D=

Hyperlinks

Downstream Pipe
B <Geometry>

<Collection: 0 itermns:
<Collection: 0 itermns:
P-9

# [m) 57.65
' [m) 233.88

E Active Topology
|5 Active? True

E Initial Settngs
Statusz [Initial] Active
Setting Type Prezsure
Prezzure Setting [Initial] [kPa) 390.0

E Operational
Controls «<Collectior::

evation [m] 165.00

Inztallation vear 1]
Zone <Mone> i
Diiameter [V alve] [mm) 1580.0
Specify Local Minor Logs? True
Minor Lozz Coefficient (Local] | 0.000
Pattern [Valve Settings] Fixed
Walve Type Butterfly

E Transient [0perational]
Operating Rule Fixed

E Water Quality
Age (Initial] (hours) 0.000
Concentration [Initial] (mg/L] 0.0
Trace [Initial] [%) 0o

E Results
Flow [L#min) [N/&)
Welocity [mdz] M)
Headlozs [m] M) -

Physica

7. Enter the following data for each of the junctions. Leave all other fields set to their default values.

Junction | Elevation Zo e Demand
{mj} {Ifrmin)
J-1 184 Aorne-1 38
J-2 185 Zone-1 31
J=3 184 Zone-1 34
J-4 1873 Aone-| 38
J-5 185.5 Fona-1 350
J-6G 165 Zong-2 356

In order to add the demand, click the ellipsis _'I

in the Demand Collection

field to open the Demand box, click New, and type in the value for Flow (L/min).

2-12
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Demands {Junction: J-1) i #

B

Flow (Base) Pattern {Demand)
(L fmim)
1 Fixed

Specify user-defined lengths for pipes P-1, P-7, P-8, P-9 and P-10. a. Click pipe P-1 to open
the Pipe Editor.

b. Set Has User Defined Length? to True. Then, enter a value of 0.01 m in the Length (User Defined)
field.

Note that the default display precision will cause only “0” to be displayed. To change display
precision, right click the column heading and select Units and Formatting to open the Set Field
Options dialog; from here you can change the Display Precision to the desired value and click OK.

Since you are using the reservoir and pump to simulate the connection to the main distribution system,
you want headloss through this pipe to be negligible. Therefore, the length is very small and the
diameter will be large.

c. Enter 1000 mm as the diameter of P-1.

E Physicd
Zone <Nones
Diarneter [mm) 1,000.0
M aterial Ductile lran
Hazen-Willams C 130.0

Has User Defined Length? Tiue
Length [User Defined) [m) nm
Haz Check Valve? Falze
Specify Local Minor Loss? True
Minor Loze Coefficient [Local]) 0,000
Installation vear 1]

d. Change the lengths (but not the diameters) of pipes P-7 through P-10 using the following user-defined
lengths: P7 = Length (User Defined): 400 m
P8 = Length (User Defined): 500 m
P9 = Length (User Defined): 31 m
P-10 = Length (User Defined): 100 m

e. Close the Properties editor.
Step 4: Entering Data through FlexTables
It is often more convenient to enter data for similar elements in tabular form, rather than to individually open

the properties editor for an element, enter the data, and then select the next element. Using FlexTables, you can
enter the data as you would enter data into a spreadsheet. To use FlexTables
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1. Click FlexTables
FlexTables

i

Tables - Project -
Tables - Shared

Tables - Predefined
-] Fire Flow Mode Table
m Flushing Report
-] Pipe Table

] Junction T able

] Hudrart T able

] Tark Table

[ Reservair Table
-] Pump T able

m Wariable Speed Pump Battery Table
- PRY Table

- PSV Table

- PBY Table

-] FCV Table

] TCW Table

-] GPY Table

] lsolation Yalve Table
] Spot Elevation T able
] i valve Table

. Hudmnneumatic: Tank Tahle LI or ChOOSC View > FlexTables'

2. Double-click Pipe Table. Fields that are white can be edited, yellow fields can not.

Fill lexTable: Pipe Table (MYLESSON1.wtg) o x|
FIBREE X 2la-12-"%-

D Label Length Start Node Stop Node Diametar [Material Hazen-Wiliams | Has Check Minar Loss

(Scaled) {mm} < Valve? Coefficient
(m) (Local)
30: P-1 30|P-1 93.35=R-1 PMP-1 1,000.0 Ductile Ir. 130.0 ] 0.000
34 P2 34 .pP-2 115.95 PMP-1 J1 152.4 Ductile Ir. 130.0 ] 0.000
36: P-3 3% P-3 195.95 J-1 )z 152.4 Ductile Ir. 130.0 O 0.000
38: P4 38 P-4 243,96 :)-2 33 152.4 Ductile Ir. 130.0 O 0.000
<0: P-5 40 P-5 195.30:3-3 J4 152.4 Ductile Ir. 130.0 O 0.000
41: P-6 41 P-6 243.32 )4 31 : 152.4 Ductile Ir. 130.0 0 0,000
43: P-7 43 p-7 88.24 133 i3S i 152.4 Ductile Ir. 130.0 O 0.000
461 P8 4% P-8 78,5236 PRV i 182.4 Ductile [r. 130.0 0 0,000
47: P9 47 P9 85.01 PRY-1 4 i 1524 Ductie Ir. 130.0 ] 0,000
49; P-10 49 P-10 6164 T-1 33 i 152.4 Ductile Ir 130.0 ] 0,000
< | 1|

10 0f 10 slements displayed [ \ 4

3. For each of the pipes, enter the diameter and the pipe material as follows:
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Pipe Material |Diameter
(mm)
P-1 Ductile [ron 1000

P-2 Cuctile lron 150
P-3 Ductile lron 150
P-4 PVC 150
P5 Cuctile lron 150
FP-& Cuctile lron 150
P-7 PVC 150
P2 Ductile lron 150
P-g Cuctile lron 150
P10 Cuctile lron 150

4. In order to enter the material type, click the ellipsis EE to open the Engineering Libraries box. Click on
Material Libraries > Material Libraries.xml and then click the appropriate material type and then click
Select.

..,,_/ Engineering Libraries ﬂ

- - X @ (=

----- ‘E| Matural stream, clean ;I E <General>

M atural stream, stony notes Engineering Feference Guio 09620057 -afeb-4c3d-beda-63944
Matural stream, weedy Engineering Libramy Source  C:\Documents and Settingshall L
FC = Material Properbes

Riveted steel [new, rough) Label VT

Riveted steel [new, smooth] Motes Young's Modulus, Poisson's Ratio;
Rock cut Futters W Coefficient 0.0

Rock riprap. 150 mm [E in] D50 tanning's Coefficient 0.m

Rock riprap, 300 mm [12 in) D50 Hazeniliams C Coefficier 150

Fiough channel, with grass Fioughness Height [m] 0.0000

Rough earth Young's Modulus [kPa) 3,300,000.0

Fiough rocks Poizzon's R atio 0.45

Steel and Aluminum 51 and 3x1 Corrugati
Steel and Aluminum 18 Inoor less CR 3x1 C
Steel and Aluminum Yar CR

Steel and Aluminum ar CR Historic

Steel structural plate 18 1n CR

Steel structural plate 31 In CR

Steel structural plate 47 In CR

L Stone mazonmy =
= el | _'I_I

Select Cloze Help
| | |

5. Notice that the C values for the pipes will be automatically assigned to preset values based on the material;
however, these values could be modified if a different coefficient were required.

6. Leave the other data set to their default values. Click to exit the table when you are finished.
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Filli FlexTable: Pipe Table (MYLESSON1.wtg) . = Ellﬂ
BBE LD -E%-
D Label Length Start Mode Stop Mode Diameker IMaterial Hazen-‘iliams | Has Check Minor Loss
(Scaled) () Valve? Coefficient
{m} (Local)
30: P-1 30§P-1 93,35 R-1 PMP-1 1,000,0 ; Duckile Ir... 130.0 [, 0,000
34:P-2 34 P2 115,95 PMP-1 X1 150.0 :Duckile I... 130.0 O 0.000
36: P-3 36:P-3 195,95 1-1 1z 150.0 : Ductile Ir... 130.0 7] 0.000
38: P-4 38:P-4 243,96 1-2 15 150.0 : PY'C 150.0 =] 0.000
40: PS5 40:P5 195.30 1-3 T 150.0 :Duckile Ir... 130.0 =) 0.000
41 P& 41 P& 24332 14 X1 150.0 : Duckile Ir... 130.0 ] 0.000
43: P-7 43:P-7 80.24 -3 15 150.0 :PYC 150.0 ] 0.000
46: P-8 46 P-8 78.52 )-f PRY-1 1500 Ductile Ir 130.0 ] 0.000
47: P9 47 (P9 85,01 PRY-1 14 150.0 :Duckile Ir... 130.0 =] 0.000
49; P-10 49:P-10 61,64 T-1 ) 150.0 : Duckile Ir... 130.0 [5], 0.000
< I
|1|] of 10 elements displayed | A

Step 5: Run a Steady-State Analysis

1. Click szl to open the Calculation Options manager.

2. Double-click Base Calculation Options under the Steady-State/EPS Solver heading to open the
Properties editor. Make sure that the Time Analysis Type is set to Steady State.

Calculation Times

Simulation Start D ate 1142000
Tirne Analysiz Type Steady State
Ilze zsimple controls duning ste True

|z EFS Snapzhot?? Falze

Start Time 12:00:00 Ak

Close the Properties editor and the Calculation Options manager.

3. Click Compute to analyze the model.

4. When calculations are completed, the Calculation Summary and User Notifications open.

5. A blue light is an informational message, a green light indicates no warnings or issues, a yellow light
indicates warnings, and a red light indicates issues.

6. Click to close the Calculation Summary and User Notifications dialogs.

7. Click to Save H project.
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